Servidor PHP Update 5.4

Con el fin de servir mejor a nuestros clientes , Dataservicios realizo una actualización importante en la configuración por defecto de sus servidores LINUX. La versión por defecto de PHP empleado por nuestros servidores se actualizará para PHP 5.4 .

Este cambio garantizará un entorno de alojamiento más seguro y estable en el futuro. Para ayudar a hacer esta transición lo más suave posible , por favor, ingrese a su cPanel y poner a prueba todos sus sitios usando PHP 5.4 , siga estos pasos:

  1. Acceda a su cPanel en https://yourdomain.com/cpanel
  2. Haga clic en el icono de ” Configuración de PHP ” , que se puede encontrar en el grupo de iconos de cPanel “avanzada” (Advanced).
  3. De la lista desplegable de los manipuladores de PHP disponibles , por favor seleccione ” PHP 5.4 ” sin cambiar el directorio de destino de la configuración actual. Se debe mostrar / ( carpeta actual ) . Haga clic en “Actualizar “
  4. Usted debe ver un mensaje de confirmación que dice: ” . Php” La extensión del archivo será procesado por PHP 5.4 para esta cuenta. Al hacer clic en el botón ” Volver” botón que ahora debe notar que la lista desplegable debe enumerando PHP 5.4 como el controlador activo.
  5. En este punto, usted querrá probar los sitios abriendo en un navegador y ver si se cargan con los errores. Si usted no nota ningún problema esto significa que sus sitios son compatibles con PHP 5.4 y no es necesario realizar ninguna acción adicional – simplemente coloque el aparato manipulador como es, sin ningún otro cambio .
  6. Si por el contrario , loque hace provoca notificación durante la prueba con sus sitios , mientras que el PHP 5.4 Manejador está habilitado, simplemente restablecerla a usar “PHP 5.2 ” . Esto establecerá su cuenta para utilizar específicamente la versión de PHP , una vez que se realiza el proceso de actualización de PHP. Estos ajustes se mantendrán una vez terminado.

Algunas Preguntas:
1 ) ¿Por qué estás haciendo este cambio?

La versión por defecto de PHP que nuestros servidores están utilizando actualmente ; PHP 5.2 ; ha sido amortizados durante algún tiempo . Como tal , nos gustaría ver a sus sitios a disfrutar los beneficios de seguridad y rendimiento de las nuevas versiones de PHP que ya tenemos disponibles en el servidor.

2 ) ¿Cómo puedo asegurarme de que mis sitios trabajarán ?

Si bien estamos tomando todas las medidas posibles para tratar de asignar la versión correcta de todos los scripts de forma automática, sí queremos pedirles que por favor entra en tu cPanel y poner a prueba todos sus sitios , como se describe anteriormente. Una vez más , nuestro sistema recordar y respetar los resultados de la prueba manual!

3 ) ¿Mi experiencia en el sitio ningún tiempo de inactividad ?

El cambio entre las versiones de PHP es simplemente un cambio de configuración en el archivo htaccess . ( S.) PHP 5.4 ya está instalado en nuestros servidores , y no hay ningún tipo de mantenimiento que deben realizarse en el propio servidor que haría que cualquier interrupción de servicio. Las aplicaciones que no son compatibles con PHP 5.4 no se cargarán correctamente una vez que se realiza el cambio. Una vez más, si bien vamos a hacer todo lo posible para comprobar automáticamente la compatibilidad para cada cuenta y establecer la versión apropiada de PHP para usted , por favor, realice la prueba de compatibilidad de su fin , así ( utilizando los pasos enumerados anteriormente ) antes de realizar este cambio.

4 ) ¿Quién puede ayudarme a actualizar mi sitio / script para usar una versión más reciente de PHP?

No vamos a ser capaces de volver a codificar su sitio para que sea compatible con las nuevas versiones de PHP. Usted debe contactar con el autor / desarrollador de la secuencia de comandos para preguntar si o no tienen actualmente o planean volver a diseñar su código para utilizar versiones posteriores de PHP.

5) ¿Qué versiones de software y estás probando la compatibilidad ?

Nuestra exploración pondrá a prueba para la compatibilidad con los siguientes programas: WordPress ( versiones 3.0 y anteriores ) Joomla ( 2.5 y superiores) Drupal ( 7 y superiores) Todas las cuentas que contienen secuencias de comandos para los programas antes mencionados que no logran el proceso de registro se establecen para utilizar PHP 5.2 .

6) ¿Qué pasa si ya tengo una configuración personalizada para PHP para uno de estos programas?

El proceso de conversión también no modificará las cuentas que ya tienen una directiva de controlador en su . Htaccess de su directorio personal.

7 ) ¿Qué pasa si estoy utilizando un programa distinto de los tres en la lista?

Cualesquiera otros scripts, para cualquier otro programa , se ajustarán automáticamente a usar PHP 5.2 . Esperamos que no había problemas con esta actualización. Sin embargo , no podemos garantizar la compatibilidad con los complementos de terceros para estos programas (temas, plugins , etc ) y de nuevo le instamos a probar sus sitios utilizando el método anterior antes de realizar esta actualización.